I have been playing with Ruby on Rails and I am very impressed so far. I need to thank Bryce for pointed out what a great tool this is and recommending that I check it out. I found the Rolling with Ruby on Rails, Part 1 and Rolling with Ruby on Rails, Part 2 tutorials very helpful. However, I have found that the Four Days on Rails documentation wasn’t as helpful.
The source code provided for the to do tracking application doesn’t appear to work under the WEBrick web server.

F:\Ruby\rails\todo>ruby script/server
f:/ruby/install/lib/ruby/site_ruby/1.8/rubygems.rb:144:in `activate’: can’t acti
vate activesupport (= 1.1.1), already activated activesupport-1.0.4] (Gem::Excep
tion)
from f:/ruby/install/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:2
3:in `require’
from f:/ruby/install/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/acti
ve_support/dependencies.rb:197:in `require’
from ./script/../config/..//config/environments/development.rb:6
from f:/ruby/install/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/acti
ve_support/dependencies.rb:189:in `load’
from f:/ruby/install/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/acti
ve_support/dependencies.rb:189:in `load’
from f:/ruby/install/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/acti
ve_support/dependencies.rb:38:in `require_or_load’
from f:/ruby/install/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/acti
ve_support/dependencies.rb:21:in `depend_on’
from f:/ruby/install/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/acti
ve_support/dependencies.rb:167:in `require_dependency’
from f:/ruby/install/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/acti
ve_support/dependencies.rb:167:in `require_dependency’
from ./script/../config/environment.rb:45
from f:/ruby/install/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:1
8:in `require__’
from f:/ruby/install/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:1
8:in `require’
from script/server:42
F:\Ruby\rails\todo>

I know that Ruby supports multiple versions and I installed rails version 0.12.1 via “gem install rails –version 0.12.1″ that the provided source code is supposed to be compatible with. I verified that the installation was successful by comfirming the installed versions:

F:\Ruby\rails\todo>gem list –local
F:\Ruby\rails\todo>”f:\ruby\install\bin\ruby.exe” “f:\ruby\install\bin\gem” list
–local
*** LOCAL GEMS ***
actionmailer (1.0.1, 0.9.1)
Service layer for easy email delivery and testing.
actionpack (1.9.1, 1.8.1)
Web-flow and rendering framework putting the VC in MVC.
actionwebservice (0.8.1, 0.7.1)
Web service support for Action Pack.
activerecord (1.11.1, 1.10.1)
Implements the ActiveRecord pattern for ORM.
activesupport (1.1.1, 1.0.4)
Support and utility classes used by the Rails framework.
fxri (0.3.2)
Graphical interface to the RI documentation, with search engine.
fxruby (1.4.2, 1.2.6)
FXRuby is the Ruby binding to the FOX GUI toolkit.
rails (0.13.1, 0.12.1)
Web-application framework with template engine, control-flow layer,
and ORM.
rake (0.6.2)
Ruby based make-like utility.
sources (0.0.1)

This package provides download sources for remote gem installation
Any ideas? Does it matter that version 0.12.1 was installed after the newer version 0.13.1?